Old posts

Hi,

so, the website changed. I found only one way of transferring the old blog to the new one: copy & paste. So, I copied everything worth copying. There is one disadvantage: the date is reset to today. For most posts that won’t really matter, but it’s good knowing that I didn’t have my QSO with Rob PA3CNT today.

Yes there is life after all

It’s been quite a while, but yes, this is a sign of life. I’ve been very busy with PI4AA, amateur radio, exercising, and other stuff. Now, I’ve spend some time on my IT infra, finally getting the VPN working, and my e-Mail the way I want. And yes, I’ve been away on vacation. First to Japan, already over a year ago, and more recently to Tanzania. Both countries are completely different, but both are amazing in their own right.

OpenWRT, OpenVPN and DNS

So, I had a few issues on my router:

  • No VPN
  • I had to use a different setting In Apple Mail on all of my devices when at home from when outside

The issue started when I upgraded my router. New OpenWRT firmware and all settings got lost.

Installing OpenVPN is easy enough, just do some ‘opkg update; opkg install openvpn’. There are enough resources on the internet about easy-pki to build your basic CA infra and generate some keys for the server and clients.

Getting things to work was a bit more effort. I was planning on bridging the VPN into the LAN. But well, a routed VPN seems to be a bit easier to get going. And really, there is no reason why a routed VPN can’t work.

Issue 1: pushing the route. I don’t want everything to go via the VPN, so I needed to know how to push routes. Eventually google knows the answer:

uci add_list openvpn.sample_server.push=“route 172.16.6.0 255.255.255.0”

That is different from setting the default route, but it works.

Issue 2: pushing DNS. Well, there are again plenty resources on the web on how to do that, but for some reason dnsmasq just doesn’t reply, or the replies don’t reach the VPN client. So, I setup a DNS resolver on the my Synology NAS. That one does reply to VPN clients. So despite all the help google had to offer, I resolved to another resolver.

uci add_list openvpn.sample_server.push=“option DNS <Synology NAS>”
uci add_list openvpn.sample_server.push=“option DOMAIN pipsworld.nl”

Left me with some firewall issues. By default the VPN is not in a zone. So, I had to add the VPN to the internal zone. I don’t really recall how I did this, but I think I eventually added The following line to the “lan” zone:

    list device ‘tun0’

This left me with forwarding from the VPN to the LAN not actually working, so I added an additional section:

config forwarding
    option src ‘lan‘
    option dest ’lan‘

My other issue was a bit different. I had never configured the ‘local’ parameter in dnsmasq, leaving it to the default setting of ‘/lan/‘, and had selected ‘int.pipsworld.nl’ as my internal domain. While that worked fine most of the time, my mailserver was internally known by a different hostname and IP-address than externally. Finally the solution was simple: drop the ‘int.’ Part of the internal domain and add some cname records to the dhcp configuration. Of course, the latter part is not in the GUI, but running some command line is not a big deal:

uci add dhcp cname
uci set dhcp.@cname[-1].cname=“mail.pipsworld.nl,www.pipsworld.nl,www.fam-post.nl”
uci set dhcp.@cname[-1].target=“classified”
uci commit dhcp
/etc/init.d/dnsmasq restart

This was a much better solution than adding the ‘reflection’ option to the DNAT firewall rules.

Web-based remote control

Inspired by things like René, PC7X repeater status page I thought it should be possible to remotely control my FT-817nd (or any CAT-equipped rig for that matter). Of course there are already a few solutions:

  • RemoteRig: a hardware solution for transceivers with a detachable head like the Yaesu FT-8900 or Icom IC-7100
  • HRD: ham radio deluxe can connect to a ‘remote’ HRD, of course this requires 2 PC’s and windows on both
  • Icom’s remote solution, that requires a specific type of RIG with ethernet or a windows PC connected to the RIG at one end, and windows with the Icom software on the other end.

I don’t like MS windows, so that is one issue, one that disqualifies the last to solutions. And the FT-817nd has a fixed head, so that disqualifies the first. And, that is true for so many rigs.

So I started a small project to build a web-based solution. The first steps have been made I can display the FT-817’s frequency and TX/RX status led. It turns out that the FT-817nd has a severely limited CAT interface. But fortunately also a number of undocumented features…

Bias-Tee (PTT via coax insert)

So, the Bulgarian Trasverter supports PTT via Coax, or VTT as they call it. Basically, all you have to do is apply 5 to 15 volt DC offset on the coax coming from the back-end transceiver during transmission. There are plenty of schematics out there to do so, no worries. Basically there is a small (10 nF) capacitor in line and a coil feeding the DC offset.

Nice thing: the Yaesu FT817nd has a PTT output, an open collector NPN transistor and 13 volt readily available on the ACC socket. With a PNP transistor and two resistors this makes for a perfect VTT source. So, all I had to do was:

  • build the Bias-Tee on one side of a PCB
  • build the VTT circuit on the other side
  • Box it up in a tin-plate box
  • Add some connectors

Et voila:

Bias Tee
Bias Tee

Hook it up to the FT-817nd and it looks like:

FT-817nd with Bias Tee
FT-817nd with Bias Tee

13 transverter and amp (2)

So, yesterday another milestone and a small setback. First the setback: my power supply is a meat 28 volt and 320 Watt, which seems to be too little for the transverter and amplifier.

And therein lies the good news: the amp has been powered up, connected to the transverter and put to work. Hans, PE1CKK, was nice enough to assist in the tuning of the amp and we finally measured over 60 Watt of output power. Now, I know that I’ll loose at least one dB of that in the relay and cables. So, if I want to do things right, I have to use better, shorter cables. Semi-rigid coax comes to mind. But, If I replace my current RG-316 coax by 3mm semi-rigid, I’ll have to do it all the way, not just from the amp output to the relay, but also from relay to receiver input. I’ll think about it. For now, let’s just get things working. As you can see from the picture below, the sequencer board is not yet connected and  installed, so that has to go in first. And, I need a bigger PSU!

img_0406

Korg nanoKONTROL2 and Studio One

I got myself a Korg nanoKONTROL2 to work with Persons Studio One. The nanoKontrol2 was only € 44,- and well, that is not much money for what it is.

Presonus recommends using the nanoKontrol in what they call Mackie mode, the Korg manual refers to this mode as Cubase mode. This works, sort of. The pan pots are bit of a thing, going only from 40% right to 90% left or so, but other than that things work as expected. BTW. the org unit may look cheapish on some pictures, but the faders and knobs, though not very big, do feel nice.

But, I wasn’t quite happy with the setup in Studio One as Persons made it for this tiny controller. I wanted to use the knobs and faders as I see fit. Fortunately, Studio One offers the opportunity to define your own midi control surface the way you like it. Just select “New Control Surface” when adding an external device rather than the Kort nanoKONTROL2 predefined option.

The next step is to set the nanoKONTROL in “CC” mode. This can be done when you plug in the device by holding down ‘set’ and ‘cycle’, but I found the Korg software to be just as useful. You then do have to manually configure the function of each knob, first by selecting ‘MIDI LEARN’ and touching each knob and fader on the device and setting the type of know. From the same panel you can assign a number of buttons statically to a function, but most of the linking to functions you will do from the normal Studio One editor. This allows you to use the faders as usual in the main context, and to adjust the parameters of say a reverb in that context. This is a bit of work, but that is what we wanted.

There are a few things that don’t quite work as I like, but this is a lot better (IMHO) than the default setup.

First in FreeDV

Just now (18:15 UTC) I had a QSO with Rob, PA3CNT, in FreeDV on 433.525 MHz. The audio quality was somewhat suboptimal, but all relevant info could be exchanged. I’m definitely a happy camper today! (This may be a first FreeDV on 70cm in PA country!) All thanks to John, PA0ETE, who posted the movie from my previous blog posting on his website.

Below you see my laptop running FreeDV attached to the IC-7100. It’s a setup on the backrest of my couch because the USB cable is only 1.5m long.

img_0242

ps. after the first posting of this blog entry Lucas, PD0LVS, installed freeDV too, so that is a second QSO! And this time it’s even a distance worth mentioning: JO22jp <-> JO22lh.

FreeDV on the IC-7100

Inspired by Don Snodgrass K4QKY I decided to try the same with my Icom IC-7100 and my Mac. Should be simple enough, the IC-7100 has a built-in USB serial adapter for rig control using CI-V commands and audio device for analog audio in- and output.

freedv-setup

I’m using either the built-in speaker and microphone or an apple headset with integrated microphone for now. Until I’ve made a few QSOs and have some reports on my audio that will have to do.

I did have to install the SI Labs USB to UART driver and reboot but then indeed the two serial devices that are integrated into the IC-7100 did show up. The audio device was already visible in the system preferences and indeed, without much ado I could configure FreeDV to use all of that. A short movie (might take a while to load) shows me setting things up.

All I need now is another station for a first QSO….

About the configuration of the IC-7100. Be sure to select USB and DATA as mode, the display will show ‘USB-D’ on the top left. In the connectors settings menu select USB in the ‘DATA MOD’ configuration item. If you, like I did at first, select normal SSB (USB) operations and select ‘USB’ as the audio source for ‘DATA OFF MOD’ there will be a terrible amount of echo.

Using ‘USB-D’ mode has the added benefit that it’s very easy to switch from the FreeDV modem (laptop) to the normal microphone input, just (de)select the DATA mode.

PS. a longer USB cable would be welcome… 5 meter or so will do.

PS2: John posted the movie on his site as well, for a much faster experience.

PS3: I removed the movie from this blog posting… check YouTube for a new version.